Humidity problems

This is where you discuss the conditions of your crabitat -- temperature, humidity, substrate, decorating, etc.
Post Reply
User avatar

Topic author
fandt94
Posts: 622
Joined: Sun Aug 05, 2018 11:57 pm
Location: NW Indiana

Humidity problems

Post by fandt94 » Thu Sep 27, 2018 8:03 am

Up until the weather got cooler I had no issue with humidity....it seems now I find myself misting the moss pits several times a day. Any possible reasons why besides the Fall weather? I’m not sure what more I can do right now besides adding a thin layer of EE over the top of the substrate. I had planned on new pools and bubblers but can’t right now. I literally misted a couple hours ago and humidity was great...in the mid 80’s. Now it’s back down to 72%. :|

*edited to add that I just put another new calibrated hygrometer in there to see the differences. I now have 3 gauges in there*
Mom to 3 human boys, 2 dogs - Hemi & Athena, 2 cats - Fat a$$ (realname Spark Plug) & Batman & 5 PP’s - Monstro, Pinkie aka Little Bit, Shellie, other 2 unnamed

User avatar

aussieJJDude
Administrator
Administrator
Posts: 3984
Joined: Fri Feb 24, 2012 8:12 pm
Location: Melbourne, Australia

Re: Humidity problems

Post by aussieJJDude » Thu Sep 27, 2018 8:08 am

Have you calibrated the gauge recently? If not, might be worth doing so before seeing if it is in fact a problem and not just a dodgy gauge.

Sent from my SM-G935F using Tapatalk
Crabs || Fish || Shrimp || Snails || Plants || Insects

25G Nano Freshwater || 64G Freshwater Community || 90G Fancy Goldie Pond || 64G Crabitat
I've never had any problems with 'Impulse Buying'... They're just things I forgot I had planned to get || Self Designated 'HCA Pic Fan' 2012+

User avatar

Topic author
fandt94
Posts: 622
Joined: Sun Aug 05, 2018 11:57 pm
Location: NW Indiana

Re: Humidity problems

Post by fandt94 » Thu Sep 27, 2018 8:18 am

aussieJJDude wrote:Have you calibrated the gauge recently? If not, might be worth doing so before seeing if it is in fact a problem and not just a dodgy gauge.

Sent from my SM-G935F using Tapatalk
Yes I re-calibrated both the Acurite and my original digital Flukkers one. After I did this the Acurite was 3% on the high side off and the other was 2% higher. Put a new battery in the Acurite as well. I thought maybe I did something wrong so I did it yet again and both were still off. I went ahead and ordered a new Acurite and calibrated it last night...it was at 75% so I just went and put that one in the tank to see what’s going on.
Mom to 3 human boys, 2 dogs - Hemi & Athena, 2 cats - Fat a$$ (realname Spark Plug) & Batman & 5 PP’s - Monstro, Pinkie aka Little Bit, Shellie, other 2 unnamed

User avatar

aussieJJDude
Administrator
Administrator
Posts: 3984
Joined: Fri Feb 24, 2012 8:12 pm
Location: Melbourne, Australia

Re: Humidity problems

Post by aussieJJDude » Thu Sep 27, 2018 8:40 am

Could possibly be your heating system which is drying up your home, basically sucking up the moisture like a sponge.

Sent from my SM-G935F using Tapatalk
Crabs || Fish || Shrimp || Snails || Plants || Insects

25G Nano Freshwater || 64G Freshwater Community || 90G Fancy Goldie Pond || 64G Crabitat
I've never had any problems with 'Impulse Buying'... They're just things I forgot I had planned to get || Self Designated 'HCA Pic Fan' 2012+

User avatar

Topic author
fandt94
Posts: 622
Joined: Sun Aug 05, 2018 11:57 pm
Location: NW Indiana

Re: Humidity problems

Post by fandt94 » Thu Sep 27, 2018 8:56 am

aussieJJDude wrote:Could possibly be your heating system which is drying up your home, basically sucking up the moisture like a sponge.

Sent from my SM-G935F using Tapatalk
No heat on yet that’s why I’m clueless. So about an hour after misting moss pit and a make shift mossy corner the readings are as follows:

Old Acurite (new batt and re-cal) = 78% but was 3% off so 75%
New one = 81%
Flukkers = 88% but was 2% off after calibrating so 86%

All are in the same area of the tat so I could get similar readings. This is frustrating! :|

Nothing has changed inside the tat...mesh lid still covered in Saran Wrap and also with a towel. My substrate is 5:1 recommended on here and up until the outside temps got cooler with a lack of humidity I’ve had no issues.
Mom to 3 human boys, 2 dogs - Hemi & Athena, 2 cats - Fat a$$ (realname Spark Plug) & Batman & 5 PP’s - Monstro, Pinkie aka Little Bit, Shellie, other 2 unnamed

User avatar

RiNiKy506
Posts: 863
Joined: Fri Sep 07, 2018 5:08 pm

Humidity problems

Post by RiNiKy506 » Thu Sep 27, 2018 9:52 am

Maybe the towel is also taking up some of the humidity? Try to dampen part of the towel that is directly on top of your lid so it’s not soaking up the humidity. Cover your top with tinfoil, then plastic wrap over the foil. I covered the openings in my tank with tinfoil and that really helped a lot with heat and humidity. I have one of the glass canopy lids for my 29 gal and that fits perfectly into the top of the tank. Can you get a glass canopy top? I’m really not sure, I’m just trying to give you some ideas. I hope you get it figured out. ♡


♡ Rod ♡ Salty ♡ Bob ♡ Squirt ♡ Crabina ♡
»-♡-> Our Purple Pinchers »-♡->

User avatar

Topic author
fandt94
Posts: 622
Joined: Sun Aug 05, 2018 11:57 pm
Location: NW Indiana

Re: Humidity problems

Post by fandt94 » Thu Sep 27, 2018 11:53 am

RiNiKy506 wrote:Maybe the towel is also taking up some of the humidity? Try to dampen part of the towel that is directly on top of your lid so it’s not soaking up the humidity. Cover your top with tinfoil, then plastic wrap over the foil. I covered the openings in my tank with tinfoil and that really helped a lot with heat and humidity. I have one of the glass canopy lids for my 29 gal and that fits perfectly into the top of the tank. Can you get a glass canopy top? I’m really not sure, I’m just trying to give you some ideas. I hope you get it figured out. ♡


♡ Rod ♡ Salty ♡ Bob ♡ Squirt ♡ Crabina ♡
»-♡-> Our Purple Pinchers »-♡->
Thanks for the tips! I don’t think the towel is taking up any of the humidity since it’s not something new that I’ve added...it’s more there to help with heat and unwanted light at night. I do have press n seal covering the current mesh lid...but of course, it was summer and humid outside the tank up until the last few days. I definitely am thinking of getting a glass canopy at this point since it seems I am now having issues. I had originally planned on upgrading my tank to a 55 gallon I recently bought but I’m going to wait several months on that now. I want to see if I can stabilize this tank without having to keep misting.

Right now it seems to be okay. I think the one gauge is either wonky or it is indeed just lower humidity where I have it because I moved the new gauge to the opposite side of the tank and it’s reading 84% where as the old on is reading 72%...and it was off +3% after calibration. I’m going to switch them now and check the readings in a bit again. This has just got me scratching my head... :?:
Mom to 3 human boys, 2 dogs - Hemi & Athena, 2 cats - Fat a$$ (realname Spark Plug) & Batman & 5 PP’s - Monstro, Pinkie aka Little Bit, Shellie, other 2 unnamed

User avatar

aussieJJDude
Administrator
Administrator
Posts: 3984
Joined: Fri Feb 24, 2012 8:12 pm
Location: Melbourne, Australia

Re: Humidity problems

Post by aussieJJDude » Thu Sep 27, 2018 6:00 pm

As long as the humdity is above 70 (i try to shoot a min of 75% to give a little bit of cushioning to fall back onto) you're crabs should be fine.

Sent from my SM-G935F using Tapatalk
Crabs || Fish || Shrimp || Snails || Plants || Insects

25G Nano Freshwater || 64G Freshwater Community || 90G Fancy Goldie Pond || 64G Crabitat
I've never had any problems with 'Impulse Buying'... They're just things I forgot I had planned to get || Self Designated 'HCA Pic Fan' 2012+

User avatar

Topic author
fandt94
Posts: 622
Joined: Sun Aug 05, 2018 11:57 pm
Location: NW Indiana

Re: Humidity problems

Post by fandt94 » Thu Sep 27, 2018 7:47 pm

aussieJJDude wrote:As long as the humdity is above 70 (i try to shoot a min of 75% to give a little bit of cushioning to fall back onto) you're crabs should be fine.

Sent from my SM-G935F using Tapatalk
Thanks! It was just starting to make me nervous getting as low as 72% because it’s never been that low. I left for a few hours for my sons football practice and readings in the tank are good. (Sure hope I didn’t jinx it by typing this lol)
Mom to 3 human boys, 2 dogs - Hemi & Athena, 2 cats - Fat a$$ (realname Spark Plug) & Batman & 5 PP’s - Monstro, Pinkie aka Little Bit, Shellie, other 2 unnamed

Post Reply