Page 2 of 2

Re: What went wrong?

Posted: Thu Feb 28, 2019 8:26 am
by Plasmoc
Any advice about the mites? Could those be hurting him? I don’t see them anymore so they must be inside his shell


Sent from my iPhone using Tapatalk

Re: What went wrong?

Posted: Thu Feb 28, 2019 4:46 pm
by aussieJJDude
Theres mites? Must of missed that. :woops::

Are the mites mostly on top of him, or are they found throughout the crabitat? If they can be found throughout the tank, most likely they are going to be detrivous mites, and are not harmful to the crabs and act as a clean up crew of sorts. If they purely just on the crab, it could be a sign that they are predatory, and you may have to bathe him - and wash out his shells by submerging him, wait for the mites to float up and drain off the mites and repeat...)

Sent from my SM-G935F using Tapatalk


Re: What went wrong?

Posted: Fri Mar 01, 2019 6:55 am
by Plasmoc
They’re only on him. I don’t see any mites on the other crabs or on the substrate or food for either tank.

Do I bathe him in fresh water or salt water?


Sent from my iPhone using Tapatalk

Re: What went wrong?

Posted: Fri Mar 01, 2019 9:18 am
by aussieJJDude
Either all is fine. The water is just used to get the mites off him, since they can't breathe well underwater and will 'abandon ship'.

Sent from my SM-G935F using Tapatalk


Re: What went wrong?

Posted: Fri Mar 01, 2019 7:27 pm
by Plasmoc
I gave him a bath and some mites came out and he also cane out of the shell very clearly dead. I’m not sure what went wrong, I feel so bad


Sent from my iPhone using Tapatalk

Re: What went wrong?

Posted: Fri Mar 01, 2019 7:41 pm
by soilentgringa
They are food mites and I am sorry to say that they are eating the crab because it died. They didn’t cause the death and they aren’t harmful but they will clean up any decaying organisms as they are scavengers.


Sent from my iPhone using Tapatalk